WSE Adapter Setup

After struggling to get the WSE Adapter setup on a new dev box, I’m writing this post for posterity, so I don’t waste another three-hours getting the adapter installed….

The adapter has one prerequisite – The Microsoft Web Services Enhancements 2.0 SP3 for .Net [1] – download and run the setup; once finished, check that you have the correct version of the Microsoft.Web.Services2 assembly in your GAC, it should be version 2.0.3.0.

Microsoft.Web.Services2 Version in the GACThis is where I was coming unstuck with the install – there are several versions of MS WSE for .Net, however the BizTalk WSE Adapter seems to need SP3 (which provides the aforementioned version).

Download and install the BizTalk Adapter for WSE 2.0 [2] and its associated service pack, Service Pack 1 [3]. Once the service pack is installed, you should have a working WSE Adapter. If the user that is installing the adapter is not a member of the BizTalk Server Administrators Group, the installer will throw a message informing you that it can’t add (create?) the adapter in the BizTalk Group – simply add the adapter manually from the Admin Console.

Downloads

  1. Web Services Enhancements (WSE) 2.0 SP3 for Microsoft .NET
  2. BizTalk Adapter for Web Services Enhancement (WSE) 2.0
  3. BizTalk Adapter for WSE 2.0 Service Pack 1 Update
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s